AppDetectivePRO and DbProtect Knowledgebase Update 4.52

This month's update for our AppDetectivePRO and DbProtect Knowledgebase is now available.

Knowledgebase version 4.52 includes new and/or updated checks for vulnerabilities in MySQL, Oracle Database and SAP (Sybase) ASE, as well as, new policies regarding security configuration benchmarks from the Center for Internet Security (CIS) for Microsoft SQL Server 2008 R2, Microsoft SQL Server 2014 and MySQL 5.

New Vulnerability and Configuration Check Highlights

MySQL

  • Critical Patch Update – July 2015
    • Checks version to determines whether the database contains vulnerabilities described by Critical Patch Update – July 2015
    • Risk: High
    • Relevant CVEs: CVE-2015-2582,CVE-2015-2611,CVE-2015-2617,CVE-2015-2620,CVE-2015-2639,CVE-2015-2641,CVE-2015-2643,CVE-2015-2648,CVE-2015-2661,CVE-2015-4737,CVE-2015-4752,CVE-2015-4756,CVE-2015-4757,CVE-2015-4761,CVE-2015-4767,CVE-2015-4769,CVE-2015-4771,CVE-2015-4772
  • Auto create user not disabled
    • Verifies that MySQL is configured to not create users without a password
    • Risk: Low
    • Relevant CVEs: N/A
  • MYSQL_PWD environment variable used
    • Verifies if the MYSQL_PWD environment variable is defined in target system
    • Risk: High
    • Relevant CVEs: N/A
  • Not running as NETWORK_SERVICE account
    • Verifies the MySQL service runs under NETWORK_SERVICE account
    • Risk: Medium
    • Relevant CVEs: N/A
  • Permissions on mysql database
    • Lists all users that have permissions on mysql database
    • Risk: Medium
    • Relevant CVEs: N/A
  • Safe show database not enabled
    • Verify that the server was started with --skip-show-database option
    • Risk: Low
    • Relevant CVEs: N/A
  • Update log used
    • Verify that the server was not started with --log-update option
    • Risk: Low
    • Relevant CVEs: N/A
  • Wildcards in user hostname
    • Verify that user accounts don't have permissions on all hosts ('%')
    • Risk: Low
    • Relevant CVEs: N/A

Oracle Database

  • Critical Patch Update/Patch Set Update - July 2015
    • Checks version to determine whether the database contains vulnerabilities described by Critical Patch Update/Patch Set Update - July 2015.
    • Risk: High
    • Relevant CVEs: CVE-2015-0468,CVE-2015-2595,CVE-2015-2599,CVE-2015-2629,CVE-2015-2646,CVE-2015-2647,CVE-2015-4735,CVE-2015-4740,CVE-2015-4753,CVE-2015-4755

SAP (Sybase) ASE

  • Database is in OFFLINE state
    • Lists all databases in the OFFLINE state
    • Risk: Informational
    • Relevant CVEs: N/A

Updated Checks

Oracle Database

  • Critical Patch Update not applied on time
    • Checks for Critical Patch Update - July 2015
    • Risk: High
    • Relevant CVEs: N/A
  • Patch Set not applied on time
    • Checks for Patch Sets based on updated release dates on certain platforms
    • Risk: High
    • Relevant CVEs: N/A

SAP (Sybase) ASE

  • Latest patch not applied
    • Check for Sybase ASE 15.7 SP135
    • Risk: High
    • Relevant CVEs: N/A
  • Latest patch not applied on time
    • Check for Sybase ASE 15.7 SP135
    • Risk: High
    • Relevant CVEs: N/A

New Policies

CIS – these policies have been created with guidance from the security configuration benchmarks set by the Center for Internet Security (CIS)

  • New policy CIS v1.0.0 for SQL Server 2014 - Audit (Built-in)
  • New policy CIS v1.0.1 for MySQL 5 - Audit (Built-in)
  • New policy CIS v1.2.0 - SQL Server 2008 R2 - Audit (Built-in)

How to Update?

All AppDetectivePRO and DbProtect customers with maintenance (subscription or perpetual) in good standing can download the latest Knowledgebase Update 4.52 by visiting the Trustwave support portal at https://trustwave.com/Company/Support and selecting either the AppDetectivePRO or DbProtect product.

AppDetectivePRO customers can also update their deployment by launching the "Updater" within the product.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.