Patch Tuesday, March 2018

March is coming in like a lion with this Patch Tuesday. The release patches 73 CVEs and includes the perennial rollup advisory for Adobe Flash. Fifteen of the 73 patched CVEs are rated as "Critical", 56 of the CVEs are rated as "Important", while one CVE each is rated as "Moderate" and "Low". The "Critical" issues include four Remote Code Execution (RCE) vulnerabilities in the Microsoft Scripting Engine as well as eight vulnerabilities in the Microsoft Chakra Scripting Engine. The MS Chakra Scripting Engine is implemented in Internet Explorer 9 as an interpreter for Microsoft's JScript language

Under the large number of "Important" rated vulnerabilities include patches for Excahnge, ASP.NET, Hyper-V, Sharepoint and the Windows OS. Client side software is also affected with the usual suspects making an appearance in Internet Explorer, MS Office and Windows GDI. Also affected are Windows CredSSP and CNG. CredSSP is the Microsoft Credential Security Support Provider protocol that presents local user credentials to remote services. The vulnerability would allow an attacker to grab and relay a authenticated users credentials in order to execute code under that user context. CNG is Microsoft's Cryptography Next Generation (CNG) driver. The vulnerability in the driver would allow an attacker to access privileged information from a target system by convincing an authenticated user to run a malicious application that requires CNG validation.

So let's get to patching and hope that March goes out like a lamb.

Critical

March 2018 Adobe Flash Security Update
ADV180006
Remote Code Execution

Chakra Scripting Engine Memory Corruption Vulnerability
CVE-2018-0872, CVE-2018-0874, CVE-2018-0930, CVE-2018-0931, CVE-2018-0933, CVE-2018-0934, CVE-2018-0936, CVE-2018-0937
Remote Code Execution

Microsoft Browser Information Disclosure Vulnerability
CVE-2018-0932
Information Disclosure

Microsoft Sharepoint Elevation of Privilege Vulnerability
CVE-2018-0947
Elevation of Privilege

Scripting Engine Information Disclosure Vulnerability
CVE-2018-0939
Information Disclosure

Scripting Engine Memory Corruption Vulnerability
CVE-2018-0876, CVE-2018-0889, CVE-2018-0893, CVE-2018-0925
Remote Code Execution

Important

.NET Core Denial of Service Vulnerability
CVE-2018-0875
Denial of Service

ASP.NET Core Denial Of Service Vulnerability
CVE-2018-0808
Denial of Service

ASP.NET Core Elevation Of Privilege Vulnerability
CVE-2018-0787
Elevation of Privilege

Chakra Scripting Engine Memory Corruption Vulnerability
CVE-2018-0873
Remote Code Execution

CNG Security Feature Bypass Vulnerability
CVE-2018-0902
Security Feature Bypass

CredSSP Remote Code Execution Vulnerability
CVE-2018-0886
Remote Code Execution

Hyper-V Information Disclosure Vulnerability
CVE-2018-0888
Information Disclosure

Internet Explorer Elevation of Privilege Vulnerability
CVE-2018-0942
Security Feature Bypass

Internet Explorer Information Disclosure Vulnerability
CVE-2018-0929
Information Disclosure

Microsoft Access Remote Code Execution Vulnerability
CVE-2018-0903
Remote Code Execution

Microsoft Browser Information Disclosure Vulnerability
CVE-2018-0891, CVE-2018-0927
Information Disclosure

Microsoft Edge Information Disclosure Vulnerability
CVE-2018-0879
Information Disclosure

Microsoft Exchange Information Disclosure Vulnerability
CVE-2018-0941
Information Disclosure

Microsoft Office Excel Security Feature Bypass
CVE-2018-0907
Security Feature Bypass

Microsoft Office Information Disclosure Vulnerability
CVE-2018-0919
Information Disclosure

Microsoft Office Memory Corruption Vulnerability
CVE-2018-0922
Remote Code Execution

Microsoft SharePoint Elevation of Privilege Vulnerability
CVE-2018-0909, CVE-2018-0910, CVE-2018-0911, CVE-2018-0912, CVE-2018-0913, CVE-2018-0914, CVE-2018-0915, CVE-2018-0916, CVE-2018-0917, CVE-2018-0921, CVE-2018-0923, CVE-2018-0944
Elevation of Privilege

Microsoft Video Control Elevation of Privilege Vulnerability
CVE-2018-0881
Elevation of Privilege

Scripting Engine Memory Corruption Vulnerability
CVE-2018-0935
Remote Code Execution

Win32k Elevation of Privilege Vulnerability
CVE-2018-0977
Elevation of Privilege

Windows Desktop Bridge Elevation of Privilege Vulnerability
CVE-2018-0880, CVE-2018-0882, CVE-2018-0877
Elevation of Privilege

Windows GDI Elevation of Privilege Vulnerability
CVE-2018-0815, CVE-2018-0816, CVE-2018-0817
Elevation of Privilege

Windows Hyper-V Denial of Service Vulnerability
CVE-2018-0885
Denial of Service

Windows Installer Elevation of Privilege Vulnerability
CVE-2018-0868
Elevation of Privilege

Windows Kernel Information Disclosure Vulnerability
CVE-2018-0811, CVE-2018-0813, CVE-2018-0814, CVE-2018-0894, CVE-2018-0895, CVE-2018-0896, CVE-2018-0897, CVE-2018-0898, CVE-2018-0899, CVE-2018-0900, CVE-2018-0901, CVE-2018-0904, CVE-2018-0926
Information Disclosure

Windows Remote Assistance Information Disclosure Vulnerability
CVE-2018-0878
Information Disclosure

Windows Security Feature Bypass Vulnerability
CVE-2018-0884
Security Feature Bypass

Windows Shell Remote Code Execution Vulnerability
CVE-2018-0883
Remote Code Execution

Moderate

Microsoft Exchange Elevation of Privilege Vulnerability
CVE-2018-0940
Tampering

Low

Microsoft Exchange Information Disclosure Vulnerability
CVE-2018-0924
Information Disclosure

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.