TrustKeeper Scan Engine Update

Summary

Over the past couple weeks we have been working diligently to make enhancements to a number of web application fingerprints. These fingerprints allow the TrustKeeper Scan Engine to detect vulnerabilities in the specific context of a given web application wherever it might be installed. Applications that we focused on in this update included Jetty, Oracle Glass Fish, IBM Tivoli Storage Manager, PHP-Fusion and Microsoft FrontPage Server Extensions.

This update includes new vulnerability checks for products such as Apache HTTP Server, PHP, Microsoft .NET Framework, OpenSSL, Plesk Panel and many others.

We also made improvements to our PHP-CGI argument injection vulnerability tests to include additional detection techniques in the case only a partial fix is applied.


New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Apache

* HTTP Server mod_digest Improper Nonce Checking Vulnerability (CVE-2003-0987)

CubeCart

* Open URL Redirection Vulnerability (CVE-2012-0865)

Microsoft

* Vulnerabilities in .NET Framework Could Allow Remote Code Execution (MS12-035) (CVE-2012-0160, CVE-2012-0161)

OpenSSL

* CMS and PKCS #7 Prone To Million Message Attack (MMA) (CVE-2012-0884)
* Denial Of Service Vulnerability in mime_param_cmp and mime_hdr_cmp functions (CVE-2012-1165, CVE-2006-7250)
* OCSP Stapling Vulnerability (CVE-2011-0014)
* TLS Server Extension Code Parsing Vulnerability (CVE-2010-3864)
* TLS/DTLS + CBC Encryption DoS Vulnerability (CVE-2012-0162, CVE-2012-0164, CVE-2012-2333)

PHP

* Exif Extension Denial of Service Vulnerability (CVE-2011-0708)
* Intl Extension NumberFormatter::setSymbol Denial of Service Vulnerability (CVE-2011-1467)
* mt_rand() Integer Overflow Vulnerability (CVE-2011-0755)
* php_mysqlnd_rset_header_read() Buffer Overflow Vulnerability (CVE-2010-3062)
* Proxied FTP Denial of Service Vulnerability (CVE-2011-1469)
* Windows Code Execution via com_print_typeinfo (CVE-2012-2376)

Parrallels

* Multiple SQL injection vulnerabilities in Plesk Panel Control Panel (CVE-2011-4734)
* Multiple SQL Injection Vulnerabilities in Plesk Panel Server Admin Panel (CVE-2011-4725)
* Multiple SQL injection vulnerabilities in Plesk Panel Small Business Panel (CVE-2011-4753, CVE-2011-4763)
* SQL injection vulnerability in Plesk Panel Control Panel certificateslist cookie (CVE-2011-4847)


Existing Vulnerability Test Updates

We made some adjustments to existing vulnerability tests worth noting:

Our initial implementation of the PHP-CGI Argument Injection Vulnerabilities received an update to identify situations where only a partial fix is applied and code execution and/or denial of service is still possible. For those interested in reading further, the following CVEs are associated with this vulnerability grouping (CVE-2012-1823, CVE-2012-2311, CVE-2012-2335, CVE-2012-2336).


How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates "auto-magically" as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.