TrustKeeper Scan Engine Update

Summary

Hello, folks! First and foremost, this week's update includes vulnerability checks for three variants of the new PHP-CGI vulnerability, CVE-2012-1823 (at the moment, NVD/CVE hasn't been updated). To learn more about this vulnerability, please see our write-up on how the vulnerability can be exploited, as well as how to mitigate the vulnerability.

The ZenCart vulnerabilities included in this release were discovered by Jon Claudius. More details on these can be found in the our the TWSL2012-004 advisory.

Jon also did a great write-up on the somewhat controversial HTTP proxy filtering bypass vulnerabilities, clearly describing how to reproduce the issues at hand. Fortunately, we are able to provide coverage for these in this release.

This update also includes checks for vulnerabilities in Adobe ColdFusion, Apache HTTP Server, Bitweaver, Cisco IOS, Cisco Unified Communication Manager, DotNetNuke, OpenSSL, phpMyAdmin, ZenCart, and improvements to many others.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests added recently are as follows:

    • PHP

      • PHP-CGI Argument Injection Source Disclosure Vulnerability (CVE-2012-1823 )
      • PHP-CGI Argument Injection Remote Code Execution Vulnerability (CVE-2012-1823 )
      • PHP-CGI Argument Injection Remote File Inclusion Vulnerability (CVE-2012-1823 )
      • PHP html_entity_decode Memory Corruption Vulnerability (CVE-2010-1860)
      • PHP php_mysqlnd_rset_header_read() Buffer Overflow Vulnerability (CVE-2010-3062)
      • PHP php_mysqlnd_read_error_from_line() Buffer Overflow Vulnerability (CVE-2010-3063)
      • PHP php_mysqlnd_auth_write() Stack Buffer Overflow Vulnerability (CVE-2010-3064)
    • ZenCart

      • ZenCart Cross-Site Scripting Vulnerability in db_username Parameter in /zc_install/index.php Page (CVE-2012-1413)
      • ZenCart XSS Vulnerabilities in main_page and language parameters of zc_install/index.php page (CVE-2012-2453, CVE-2012-2454)
      • ZenCart Local File Inclusion Vulnerability in main_page and language parameters (CVE-2012-2433, CVE-2012-2434)

    • phpMyAdmin

      • phpMyAdmin show_config_errors.php Path Disclosure Vulnerability (CVE-2012-1902)
    • Apache HTTP Server

      • Apache HTTP Server Zero-Length Directory Name in LD_LIBRARY_PATH Vulnerability (CVE-2012-0883)

    • Adobe ColdFusion

      • Adobe ColdFusion Administrator Guessable Admin Password

    • Cisco Unified Communications Manager

      • Unsupported Version of Cisco Unified Communications Manager
      • Cisco Unified Communications Manager Multiple Denial of Service Vulnerabilities via Memory Leak (CVE-2011-1604)
      • Cisco Unified Communications Manager Multiple Denial of Service Vulnerabilities via SIP REG Message (CVE-2010-0591)

    • OpenSSL

      • OpenSSL Encoded ASN.1 Data Incomplete Fix Memory Corruption Vulnerability (CVE-2012-2131)

    • Cisco IOS

      • Cisco IOS Malformed IPv6 Packet Denial of Service Vulnerability (CVE-2011-0944)

    • DotNetNuke

      • BitWeaver

        • Multiple XSS Vulnerabilities in Bitweaver 2.0.0 & Earlier (CVE-2007-6374)
        • Bitweaver SQL Injection Vulnerability in sort_mode & highlight Parameters (CVE-2007-6375)

        How to Update?

        All Trustwave customers using the TrustKeeper Scan Engine receive the updates "auto-magically" as soon as an update is available. No action is required.

          Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.