TrustKeeper Scan Engine Update – February 16, 2015

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available.

This week we've included 19 new vulnerability checks. We also included a check for the techniques described by Chris Gates (@carnal0wnage) in a recent blog post on how to extract Cisco ASA version information without the need for authentication. Thanks Chris!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Adobe

Cisco

  • Cisco ASA CIFS Share Enumeration Denial of Service Vulnerability (CSCuj83344) (CVE-2013-6691)
  • Cisco ASA Clientless SSL VPN Information Disclosure and Denial of Service Vulnerability (CSCuq29136) (CVE-2014-3392)
  • Cisco ASA Clientless SSL VPN Portal Customization Integrity Vulnerability (CSCup36829) (CVE-2014-3393)
  • Cisco ASA Health and Performance Monitor Denial of Service Vulnerability (CSCum00556) (CVE-2014-3385)
  • Cisco ASA IKE Denial of Service Vulnerability (CSCul36176) (CVE-2014-3383)
  • Cisco ASA IKEv2 Denial of Service Vulnerability (CSCum96401) (CVE-2014-3384)
  • Cisco ASA Smart Call Home Digital Certificate Validation Vulnerability (CSCun10916) (CVE-2014-3394)
  • Cisco ASA VNMC Command Input Validation Vulnerability (CSCuq41510 and CSCuq47574) (CVE-2014-3390)
  • Cisco ASA VPN Failover Command Injection Vulnerability (CSCuq28582) (CVE-2014-3389)

ISC

  • ISC BIND Defects in GeoIP features can cause BIND to crash (CVE-2014-8680)

PHP

  • PHP process_nested_data Use After Free Vulnerability (CVE-2014-8142)
  • PHP XMLRPC date_from_ISO8601 Denial of Service (CVE-2014-8626)
  • PHP Zend Engine Double Free Denial of Service (CVE-2014-9425)
  • PHP-CGI Out of Bounds Read Code Execution Vulnerability (CVE-2014-9427)

phpMyAdmin

  • phpMyAdmin Cross-site Scripting Vulnerability in Micro History (CVE-2014-6300)
  • phpMyAdmin Multiple Cross-site Scripting Vulnerabilities in SQL Debug Output (CVE-2014-8326)

Ruby

  • Ruby Denial of Service Vulnerability in Encoding Method (CVE-2014-4975)
  • Ruby Denial of Service Vulnerability in str_buf_cat (CVE-2014-3916)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.