TrustKeeper Scan Engine Update – October 9, 2014

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. A highlight of the update is an additional check for the recently disclosed Shellshock vulnerability in GNU Bash (CVE-2014-6271) via the Qmail vector. This week's release also includes new tests for an additional eight vulnerabilities.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

RSH

  • Default RSH credentials detected

Microsoft .NET Framework

PostgreSQL

  • PostgreSQL local file overwrite through make_oidjoins_check script (CVE-2004-0977)
  • PostgreSQL arbitrary shared library code execution through LOAD extension (CVE-2005-0227)
  • PostgreSQL EXECUTE permission bypass through CREATE AGGREGATE (CVE-2005-0244)
  • PostgreSQL buffer overflow in gram.y allows arbitrary code execution (CVE-2005-0245)
  • PostgreSQL SSL certificate spoofing and hostname validation bypass (CVE-2009-4034)
  • PostgreSQL allow privilege escalation via session state in an index function (CVE-2009-4136)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.