TrustKeeper Scan Engine Update – September 29, 2014

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave External Vulnerability Scanner (EVS) and Trustwave Internal Vulnerability Scanner (IVS) products is now available. Most notably, this week's release includes checks for the "Shellshock" vulnerability in GNU Bash (CVE-2014-6271 and CVE-2014-7169). We also added checks for 13 other vulnerabilities.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently include:

Apache Tomcat

  • Apache Tomcat Unrestricted File Upload Vulnerability (CVE-2013-4444)

Cisco

  • Cisco IOS allows ntp query with access-group configured (CVE-2014-3309)
  • Cisco IOS Denial of Service in IPSEC on ISR Codenomicon (CVE-2014-3299)

FreeBSD

GNU Bash

Joomla!

  • Joomla! Authenticated File Upload Bypass Vulnerability (CVE-2013-5576)

Ruby

  • Ruby on Rails SQL Injection Vulnerability in PostgreSQL bitstring Quoting (CVE-2014-3482)
  • Ruby on Rails SQL Injection Vulnerability in PostgreSQL range Quoting (CVE-2014-3483)

Samba

  • Samba nmbd NetBIOS Name Services Daemon Denial of Service (CVE-2014-0244)
  • Samba smbd File Server Denial of Service (CVE-2014-3493)

Squid

  • Squid Proxy Denial of Service via HttpHdrRange.cc (CVE-2014-3609)

Redis

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.