TrustKeeper Scan Engine Update - April 3, 2013

The latest and greatest release of the TrustKeeper Scanning Engine is here. This update contains coverage for 23 new vulnerabilities, including tests for Oracle Application Server, Oracle Database Server, Oracle Solaris, PHP, and Wordpress.

Additionally, the scan engine has been updated to detect Webmin UDP Broadcast services.

This update also contains a whole bunch of improvements to current tests and many other improvements to the engine itself.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

* Apache Tomcat AJP Connector Memory Disclosure Vulnerability (CVE-2006-7197)

* Vulnerabilities in Kernel-Mode Drivers Could Allow Elevation Of Privilege (MS13-027) (CVE-2013-1285, CVE-2013-1286, CVE-2013-1287)
* Vulnerabilities in SharePoint Could Allow Elevation of Privilege (MS13-024) (CVE-2013-0080, CVE-2013-0083, CVE-2013-0084, CVE-2013-0085)

* Oracle Solaris January 2012 CPU (CVE-2012-0094, CVE-2012-0096, CVE-2012-0097, CVE-2012-0098, CVE-2012-0099, CVE-2012-0100, CVE-2012-0103, CVE-2012-0109)
* Oracle Solaris April 2012 CPU (VE-2012-0539, CVE-2012-1681, CVE-2012-1683, CVE-2012-1684, CVE-2012-1691, CVE-2012-1692, CVE-2012-1694, CVE-2012-1698)
* Oracle Solaris July 2012 CPU (CVE-2001-0323, CVE-2008-4609, CVE-2011-0419, CVE-2011-2699, CVE-2012-0563, CVE-2012-1687, CVE-2012-1750, CVE-2012-1752, CVE-2012-1765, CVE-2012-3112, CVE-2012-3120, CVE-2012-3121, CVE-2012-3122, CVE-2012-3123, CVE-2012-3124, CVE-2012-3125, CVE-2012-3127, CVE-2012-3129, CVE-2012-3130, CVE-2012-3131)
* Oracle Solaris October 2012 CPU (CVE-2012-0217, CVE-2012-3165, CVE-2012-3187, CVE-2012-3189, CVE-2012-3199, CVE-2012-3203, CVE-2012-3204, CVE-2012-3205, CVE-2012-3207, CVE-2012-3208, CVE-2012-3209, CVE-2012-3210, CVE-2012-3211, CVE-2012-3212, CVE-2012-3215, CVE-2012-5095)
* Oracle January 2012 Security Update Multiple Vulnerabilities (CVE-2012-0083, CVE-2012-0084, CVE-2012-0085)
* Oracle April 2010 Security Update Multiple Vulnerabilities (CVE-2010-0086, CVE-2010-0853, CVE-2010-0855, CVE-2010-0856, CVE-2010-0872)
* Oracle July 2010 Security Update Multiple Vulnerabilities (CVE-2010-0081, CVE-2010-0835, CVE-2010-2381)
* Oracle October 2011 Security Update Multiple Vulnerabilities (CVE-2011-2314, CVE-2011-3192)
* Oracle Database Security Alert 48
* Oracle Database Security Alert 63
* Oracle Database Security Alert 65

* PHP ext/filter FILTER_SANITIZE_STRING and FILTER_FLAG_STRIP_LOW Vulnerability (CVE-2007-1454)
* PHP readfile function safe_mode bypass (CVE-2007-1710)
* PHP double free vulnerability in unserializer (CVE-2007-1711)
* PHP COM functions do not follow safe_mode and disable_functions restrictions (CVE-2007-5653)
* PHP fopen safe_mode Bypass Vulnerability (CVE-2007-0448)
* PHP sqlite_udf_decode_binary Buffer Overflow (CVE-2007-1888)
* PHP Substr_Count Integer Overflow Vulnerability (CVE-2007-2748)

* Wordpress Cross-Site Request Forgery Vulnerability in dashboard_incoming_links Edit Action (CVE-2012-4448)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.