TrustKeeper Scan Engine Update - August 29, 2012

Today marks the next update to theTrustKeeper Scan Engine and as usual, we have been slaving away in the dungeon annihilatingnew vulnerabilities with sword and shield.

This update includes a recent DellSonicWALL Scrutinizer (also know as Plixer International Scrutinizer) SQL injection vulnerability. The vulnerabilitywas discovered by muts of OffensiveSecurity, which was released during BlackHat USA and affects versions 9.0.1 and earlier (unauthenticated)and before 9.5.2 (authenticated).

A cross-site scripting vulnerability for SupportIncident Tracker (SiT!) is also included, which was discovered by SpiderLabsResearch. For more information on thisvulnerability, see our recent blog post and advisory.

As always, this update includes a number of bug fixes, supportfor new applications, and improved evidence for existing vulnerabilities.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

* Cisco ASA Denial of Service via SIP PinHoles (CSCtz63143) (CVE-2012-2472)
* Cisco ASA Clientless WebVPN Memory Leak Causes Blank Page after Authentication (CSCth34278) (CVE-2012-2474)

* JIRA XSS Vulnerabilities in Labelling and Issue Linking
* JIRA XSS Vulnerability in Administration Interface of Bamboo Plugin
* JIRA XSS Vulnerabilities in URL Query Strings
* JIRA Standalone Vulnerability with Session Cookies
* JIRA Users without the 'JIRA Users' Permission can Login via Crowd Single Sign On
* JIRA XSRF Vulnerability in 'Logout' Action
* JIRA Security Vulnerabilities in FishEye Plugin
* JIRA Security Vulnerabilities in Bamboo Plugin

* Oracle Database 9i Release 2 XML Overflow Vulnerability (CVE-2003-0727)
* Oracle Database Arbitrary SQL Command Execution via CREATE INDEX Vulnerability (CVE-2012-3132)

Plixer International
* Plixer International Scrutinizer SQL Injection Vulnerability in statusFilter.php (CVE-2012-2962)

* nginx Vulnerabilities with Windows directory aliases (CVE-2011-4963)

Support Incident Tracker
* Support Incident Tracker (SiT!) XSS Vulnerabilities in setup.php (CVE-2012-4346)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates "auto-magically" as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.