TrustKeeper Scan Engine Update - December 18, 2012

We're proud to announce we've just completed the one thing that's on everyones' holiday wish list this year: the latest update to the TrustKeeper Scan Engine! This release includes several performance enhancements, as well 52 new vulnerability tests for major applications including Apache HTTP Server, Cisco IOS, Microsoft Windows, ISC BIND, MySQL, Samba, and others.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Apache
* Apache HTTP Server mod_proxy_ajp Remote DoS Vulnerability (CVE-2012-4557)

Cisco
* Cisco SIP Denial of Service (cisco-sa-20110928-sip) (CVE-2011-3275, CVE-2011-0939)
* Cisco IOS SSLVPN DTLS Denial of Service Vulnerability (CSCty97961) (CVE-2012-3924)
* Cisco IOS SSLVPN Outbound ACL Denial of Service Vulnerability (CSCte41827) (CVE-2012-3923)
* Cisco IOS Software Interface Wedge Found While Sending Malformed Packet to UDP 465 Vulnerability (CSCts48300) (CVE-2011-4015)
* Cisco IOS Software Reload @ipv6_input Vulnerability (CSCtk53534) (CVE-2012-1324)
* Cisco IOS Software QFP Crash W GTRMP_GTR_OTHER_LEAF_INT_INT_SDMA_REGULAR_SW_ERR Due to QOS (CSCtr56576) (CVE-2011-4007)
* Cisco IOS Software Router Crash with Segmentation Fault Vulnerabilty (CSCtq61128) (CVE-2011-4231)

ISC
* ISC BIND DNS64 Denial of Service (DoS) via Crafted Query Vulnerability (CVE-2012-5688)

Microsoft
* Microsoft IIS 4 Redirect Buffer Overflow (MS04-021) (CVE-2004-0205)
* Microsoft Windows DNS Server DNS Spoofing Vulnerability (MS07-062) (CVE-2007-3898)
* Microsoft SQL Server XML Editor Information Disclosure Vulnerability (MS11-049) (CVE-2011-1280)
* Microsoft SQL Server Windows Common Controls Could Allow Remote Code Execution Vulnerability (MS12-027) (CVE-2012-0158)
* Microsoft SQL Server Windows Common Controls Could Allow Remote Code Execution Vulnerability (MS12-060) (CVE-2012-1856)
* Microsoft SQL Server Reporting Services Cross-Site Scripting Privilege Escalation Vulnerability (MS12-070) (CVE-2012-2552)
* Microsoft .NET ILASM & ILDASM Arbitrary Code Execution & DoS Vulnerability (CVE-2006-1511)
* Microsoft SQL Server DoS & Possible Buffer Overflow Via TCP 1433 Vulnerability (CVE-2004-1560)

MySQL
* MySQL Remote Preauth User Enumeration Vulnerability (CVE-2012-5615)
* MySQL Stack-based Buffer Overflow Vulnerability (CVE-2012-5611)
* MySQL Denial of Service via UpdateXML Command (CVE-2012-5614)
* MySQL Heap-based Buffer Overflow Vulnerability (CVE-2012-5612)
* MySQL Database Privilege Elevation Vulnerability (CVE-2012-5613)

Samba
* Samba LSA Privilege Escalation (CVE-2012-2111)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.