TrustKeeper Scan Engine Update - February 20, 2013

The latest update to the TrustKeeper Scan Engine is now available. It includes coverage for over 20 vulnerabilities for products such as Cisco IOS/ASA, Oracle Database, PHP, ISC BIND, Samba and OpenSSL, among others.

As always, this update also includes improvements to existing tests and better evidence reporting.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Cisco
* Cisco IOS Extended ACL is broken when ACL is used with log or time keyword (CSCts01106) (CVE-2012-0362)
* Cisco IOS and CUCM SCB Leak Results from Unexpected Response to SUBSCRIBE (CSCto93837 and CSCtj61883) (CVE-2011-4019)
* Cisco ASA HTTP response splitting (CSCth63101) (CVE-2011-3285)
* Cisco IOS HTTP Packet DoS (cisco-sa-20110928-zbfw) (CVE-2011-3281)
* Cisco IOS IPv6 Hop-by-Hop IOS Fingerprinting (CSCtq02219) (CVE-2011-2059)
* Cisco IOS IPv6 MPLS Denial of Service (cisco-sa-20110928-ipv6mpls) (CVE-2011-3274)
* Cisco IOS Permanently Caching Public Keys (CSCth82164) (CVE-2011-0935)
* Cisco IOS SSH VRF Access Restriction Bypass (CSCsv86113) (CVE-2012-0338)
* Cisco IOS Telnet VRF Access Restriction Bypass (CSCsi77774) (CVE-2012-0339)

ISC
* ISC BIND DNS64 and RPZ Denial of Service (DoS) via Crafted Query Vulnerability (CVE-2012-5689)

Microsoft
* Vulnerabilities in Outlook Web Access for Exchange Server Could Allow Elevation of Privilege (MS08-039) (CVE-2008-2248, CVE-2008-2247)

Moodle
* Moodle Backup Converter Arbitrary File Reading Vulnerability (CVE-2012-6099)

OpenSSH
* Portable OpenSSH Information Leakage (OSVDB 72183)

OpenSSL
* OpenSSL SSL/TLS and DTLS Plaintext Recovery Attack (CVE-2013-0169)
* OpenSSL TLS 1.1 and 1.2 AES-NI crash (CVE-2012-2686)
* OpenSSL OCSP NULL Key Denial of Service (CVE-2013-0166)

Oracle
* Oracle Database January 2013 Security Update (CVE-2012-3220)

PHP
* PHP "crypt_des" Password Truncation Vulnerability (CVE-2012-2143)

ProFTPD
* ProFTPD UserOwner Directive Race Condition Vulnerability (CVE-2012-6095)

Samba
* Samba SWAT Click-Jacking Vulnerability (CVE-2013-0213)
* Samba SWAT Cross-Site Request Forgery Vulnerability (CVE-2013-0214)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.