TrustKeeper Scan Engine Update - June 25, 2013

The latest update to the TrustKeeper Scan Engine is now available. It adds coverage for more than 100 vulnerabilities (yes, 100+ vulnerabilities), including several vulnerabilities from Cisco, Apache Tomcat, Bind, Joomla and PHP. It also greatly expands our vulnerability coverage for Moodle CMS with 32 new vulnerability tests. Additionally, this release also contains to tests to check for the recently released Linksys command injection vulnerabilities discovered by Jason Leyrer of SpiderLabs. For more information about the Linksys vulnerabilities, checkout Jason's detailed write up here.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Apache
* Apache Tomcat AsyncListeners Information Disclosure Vulnerability (CVE-2013-2071)
* Apache Tomcat Session Fixation Vulnerability (CVE-2013-2067)

Cisco
* Cisco IOS Software Resource Reservation Denial of Service (cisco-sa-20130327-rsvp) (CVE-2013-1143)
* Cisco Unified Communications Manager (CUCM) Partial DoS Vulnerability (CSCud39515) (CVE-2013-1188)
* Cisco Unified Communications Manager DoS During Malformed Packet Attack on Unused UDP Ports (CSCtx43337) (CVE-2013-1133)
* Cisco Unified Communications Manager DoS During Malformed Packet Attack on Unused UDP Ports (CSCue25770) (CVE-2013-1240)
* Cisco Unified Communications Manager Location Bandwidth Manager (LBM) Cache Poisoning Vulnerability (CSCub28920) (CVE-2013-1134)

ISC
* ISC BIND Recursive Resolver Denial of Service (CVE-2013-3919)

Joomla
* Joomla! Authenticated User Privilege Bypass Vulnerability (CVE-2013-3056, CVE-2013-3057)
* Joomla! Coding Errors Information Disclosure Vulnerability (CVE-2013-1454)
* Joomla! Encoded Search Term Information Disclosure Vulnerability (CVE-2013-1453)
* Joomla! Undefined Information Disclosure (CVE-2013-1455)
* Joomla! Unspecified XSS Vulnerability (CVE-2013-3058)

Linksys
* Linksys 'ping_ip' Remote Command Injection Vulnerability (CVE-2013-3307)
* Linksys 'ping_size' Remote Command Injection Vulnerability

PHP
* Joomla! remember.php PHP Serialization Vulnerability (CVE-2013-3242)
* PHP Heap Based Buffer Overflow in quoted_printable_encode Vulnerability (CVE-2013-2110)

PhpMyAdmin
* PhpMyAdmin Authenticated User Remote Code Execution via Replace Table Prefix (CVE-2013-3238)
* PhpMyAdmin Authenticated User Remote Code Execution via SaveDir (CVE-2013-3239)
* PhpMyAdmin Export Feature Directory Traversal Vulnerability (CVE-2013-3240)
* PhpMyAdmin Export Feature Superglobal Variable Overwrite Vulnerability (CVE-2013-3241)
* PhpMyAdmin XSS Vulnerabilities in tbl_gis_visualization.php (CVE-2013-1937)

Plesk
* Parallels Plesk Panel PHP-CGI remote code execution vulnerability (CVE-2012-1823)

WordPress
* Wordpress Password Protected Post Denial of Service (CVE-2013-2173)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.