TrustKeeper Scan Engine Update - November 8, 2012

The latest update to the TrustKeeper Scan Engine is now available.

This update includes coverage for over 50 vulnerabilities for products such as Cisco IOS, Microsoft Windows, ISC BIND, Oracle Database and MySQL servers, and Samba. We've been busy!

As always, this update also includes improvements to existing tests and better evidence reporting.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Cisco
* Cisco IOS MVPNv6 Update Denial of Service Vulnerability (CVE-2012-3895)

ISC
* ISC BIND Resource-Record Combination Denial of Service Vulnerability (CVE-2012-5166)

Joomla
* Joomla! Highlight Cross Site Scripting Vulnerability (CVE-2012-1117)
* Joomla RFI Vulnerability (CVE-2005-3738)

Microsoft
* Vulnerability in .NET Framework and Microsoft Silverlight Could Allow Remote Code Execution (MS11-078) (CVE-2011-1253)
* Vulnerabilities in Outlook Web Access (OWA) for Exchange Server Could Allow Elevation of Privilege (MS08-039) (CVE-2008-2248, CVE-2008-2247)
* ASP.NET Path Validation Vulnerability (MS05-004) (CVE-2004-0847)
* Vulnerabilities in the Microsoft .NET Common Language Runtime Could Allow Remote Code Execution (MS09-061) (CVE-2009-0090, CVE-2009-0091, CVE-2009-2497)
* Vulnerability in ASP.NET 2.0 Could Allow Information Disclosure (MS06-056) (CVE-2006-3436)

Oracle
* Oracle MySQL October 2012 Security Update For Multiple Vulnerabilities (CVE-2012-3144, CVE-2012-3147, CVE-2012-3149, CVE-2012-3150, CVE-2012-3156, CVE-2012-3158, CVE-2012-3160, CVE-2012-3163, CVE-2012-3166, CVE-2012-3167, CVE-2012-3173, CVE-2012-3177, CVE-2012-3180, CVE-2012-3197)
* Oracle Database October 2012 Security Update For Multiple Vulnerabilities (CVE-2012-1751, CVE-2012-3132, CVE-2012-3137, CVE-2012-3146, CVE-2012-3151)

PHP
* PHP 'ZipArchive::addGlob' and 'ZipArchive::addPattern' Denial Of Service Vulnerabilities (CVE-2011-1657)
* PHP Symbolic Links Vulnerability (CVE-2011-0754)

Samba
* Samba CAP_DAC_OVERRIDE Access-level Bypass Vulnerability (CVE-2010-0728)
* Samba Incorrect Primary Group Assignment for Users (CVE-2007-4138)
* Samba Exposure of Machine Account Credentials (CVE-2006-1059)
* Samba QFILEPATHINFO Buffer Overflow (CVE-2004-0882)
* Samba Wildcard Character Match Denial of Service (CVE-2004-0930)
* Samba Domain Logon nmbd Denial of Service (CVE-2004-0808)
* Samba Domain Logon nmbd Denial of Service (CVE-2004-0808)
* Samba Multiple Memory Exhaustion Denial of Service Attacks (CVE-2004-2546)
* Samba Interger Overflow in smbd (CVE-2004-1154)
* Samba mksmbpasswd.sh Guessable Passwords (CVE-2004-0082)
* Samba Buffer Overrun in Hash Mangling Method (CVE-2004-0686)
* Samba Remote Arbitrary File Access Vulnerability (CVE-2004-0815)
* Samba Remote Authenticated Denial of Service (CVE-2004-0829)
* Samba SWAT Pre-Authentication Buffer Overflow (CVE-2004-0600)
* Samba Local User Symlink Attack (CVE-2004-0815)
* Samba Insecure Permissions of group_mapping.ldb File (CVE-2008-3789)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates auto-magically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.