TrustKeeper Scan Engine Update - September 28, 2012

The TrustKeeper Scan Engine has been updated and is packed with even more wonderful goodness than ever before!

This update includes coverage for four recently discovered ISC BIND vulnerabilities. These vulnerabilities, when leveraged, can result in denial of service conditions and potential sensitive DNS cache information disclosure. All of these vulnerabilities are addressed as of the latest versions of BIND (9.7.6-P3, 9.8.3-P3, 9.9.1-P3, 9.4-ESV-R5-P2, and 9.6-ESV-R7-P3). We recommend upgrading to the latest versions as soon as possible.

This update also includes coverage for vulnerabilities in Oracle Enterprise Manager and Oracle MySQL Server, which were addressed in Oracle's latest Critical Patch Update (CPU) Advisory. If you haven't already applied this CPU to affected Oracle products, we recommend doing so as soon as possible.

Additionally, we've added coverage for a handful of PHP vulnerabilities including a recently discovered flaw in which attackers could use a specially-crafted URL to bypass an HTTP response-splitting protection mechanism. This bug was addressed in PHP 5.4.0, but we recommend upgrading to the latest version.

As always, a number of new vulnerability checks and improvements to existing tests were implemented based on feedback from our customers.

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Bugzilla
* Bugzilla Information Disclosure Vulnerability via Email ToolTips (CVE-2012-1968)
* Bugzilla Information Disclosure When Attachment ID Referenced in Comments (CVE-2012-1969)
* Bugzilla XSS in Javascript Template (CVE-2012-0466)

ISC BIND
* ISC BIND Long long Resource Record Query DoS Vulnerability (CVE-2012-4244)
* ISC BIND RRSIG Recursive Query Handling Denial of Service Vulnerability (CVE-2010-0213)
* ISC BIND Cache Exposure via ACL Bypass Vulnerability (CVE-2010-0218)
* ISC BIND Failure to Handle Bad Signatures if Multiple Trust Anchors Configured Denial of Service Vulnerability (CVE-2010-3762)

Joomla!
* Joomla! 2.5.x Security Bypass Vulnerability (CVE-2012-2747)
* Joomla! Sensitive Information Disclosure Vulnerability (CVE-2012-0819)
* Joomla! Cross-site Scripting Vulnerability (CVE-2012-0822)

Microsoft System Center Configuration Manager
* Vulnerability in System Center Configuration Manager Could Allow Elevation of Privilege (MS12-062) (CVE-2012-2536)

Microsoft Visual Studio Team Foundation Server
* Vulnerability in Visual Studio Team Foundation Server Could Allow Elevation of Privilege (MS12-061) (CVE-2012-1892)

Oracle
* Oracle July 2012 Security Update For MySQL Server Multiple Vulnerabilities (CVE-2012-0540, CVE-2012-1689, CVE-2012-1734, CVE-2012-1735, CVE-2012-1756, CVE-2012-1757)
* Oracle Enterprise Manager July 2012 Security Update (CVE-2012-1737)
* Oracle April 2012 Security Update Multiple Vulnerabilities (CVE-2012-0520, CVE-2012-0525, CVE-2012-0526, CVE-2012-0527)

PHP
* PHP Permitting File Access as Web Server UID when safe_mode is on (CVE-2001-1247)
* PHP PDO Extension DoS via Out of Bounds Read of Query String (CVE-2012-3450)
* PHP bzip2 and zip access surpasses open_basedir and safemode limitations (CVE-2007-1460, CVE-2007-1461)
* PHP 5.4.0 HTTP Header Response Splitting Attack Via %0D (CVE-2012-4388)

PHPList
* PHPList Admin Page XSS before 2.10.18 (CVE-2012-2741)
* PHPList Multiple XSS before 2.10.19 (CVE-2012-3952, CVE-2012-4246, CVE-2012-4247)
* PHPList SQLi before 2.10.18 (CVE-2012-2740)
* PHPList SQLi before 2.10.19 (CVE-2012-3953)

Plesk
* Plesk multiple cross-site scripting (XSS) vulnerabilities in the Control Panel (CVE-2011-4735, CVE-2011-4754, CVE-2011-4764)
* Plesk multiple cross-site scripting (XSS) vulnerabilities in the Control Panel (CVE-2011-4726)
* Plesk 10.3 multiple cross-site scripting (XSS) vulnerabilities in the Control Panel (CVE-2011-4745)
* Plesk 10.4.4 multiple cross-site scripting (XSS) vulnerabilities in the Control Panel (CVE-2011-4776)
* Plesk Missing HTTPOnly Flag in Set-Cookie Headers (CVE-2011-4765)

Wordpress
* Wordpress Private and Draft Post Information Disclosure (CVE-2012-3385)

vBulletin
* vBulletin 4.1.10 SQL Injection Vulnerability in announcement.php (CVE-2012-4686)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates "auto-magically" as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.