TrustKeeper Scan Engine Update July 1, 2015

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available.

This week we've added 30 new vulnerability checks related to Cisco IOS, FreeBSD, ISC BIND, OpenSSL, ProFTPD, and Symantec. Enjoy!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Cisco

  • Cisco IOS Access Control List Bypass Vulnerability (CSCun21071) (CVE-2015-0610)
  • Cisco IOS Autonomic Networking Infrastructure Overwite Vulnerability (CVE-2015-0669)
  • Cisco IOS Autonomic Networkinging Infrastructure Self-Referential Vulnerability (CSCup62157) (CVE-2015-0659)
  • Cisco IOS MACE Race Condition Vulnerability (CSCuj96752) (CVE-2015-0609)
  • Cisco IOS MACE Race Condition Vulnerability (CSCul48736) (CVE-2015-0608)
  • Cisco IOS Shell Denial of Service Vulnerability (CSCur59696) (CVE-2015-0606)
  • Cisco IOS Software Authentication Proxy Bypass Vulnerability (CSCun16016) (CVE-2015-0607)
  • Cisco IOS Software Authentication Proxy Bypass Vulnerability (CSCuo09400 and CSCun16016) (CVE-2015-0607)
  • Cisco IOS Vulnerability in kernel timers (CSCuh25672) (CVE-2015-0592)
  • Cisco IOS Zone Based Firewall Vulnerability (CSCul65003) (CVE-2015-0593)
  • Multiple Vulnerabilities in Cisco IOS Software (cisco-sa-20150325-ani) (CVE-2015-0635)
  • Multiple Vulnerabilities in Cisco IOS Software Common Industrial Protocol (cisco-sa-20150325-cip) (CVE-2015-0648)

FreeBSD

Generic

  • NTP Denial of Service via symmetric association man-in-the-middle (CVE-2015-1799)
  • Scan interference identified on common web ports
  • SNMPv2 GetBulk traffic amplification Denial of Service

ISC

  • FreeBSD BIND Remote Denial of Service Vulnerability (FreeBSD-SA-14:29.bind) (CVE-2014-8500)
  • FreeBSD BIND Remote Denial of Service Vulnerability (FreeBSD-SA-15:05.bind) (CVE-2015-1349)

OpenSSL

ProFTPD

  • ProFTPd Unauthenticated File Copy via mod_copy Vulnerability (CVE-2015-3306)

Symantec

  • Symantec pcAnywhere End-of-Life since 05/05/2014

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.