TrustKeeper Scan Engine Update June 17 2015

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available.

This week we bring you nine new vulnerability checks including tests for "LogJam", ClamAV, Drupal, IBM, Zen-Cart, and phpMyAdmin. Enjoy!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

ClamAV

  • ClamAV Prior to 0.98.7 crafted petite packed file DoS (CVE-2015-2222)
  • ClamAV Prior to 0.98.7 crafted xz archive file DoS (CVE-2015-2668)
  • ClamAV Prior to 0.98.7 crafted y0da cryptor file DoS (CVE-2015-2221)

Drupal

  • Session hijacking for Drupal 6.x before 6.34 and 7.x before 7.34 (CVE-2014-9015)
  • Denial of service in the password hashing API for Drupal (CVE-2014-9016)

Generic

IBM

  • IBM WebSphere Application Server Management Port Remote Code Execution (CVE-2015-1920)

phpMyAdmin

  • phpMyAdmin Token Information Disclosure Vulnerability (CVE-2015-2206)

Zen-Cart

  • Multiple Zen-Cart Cross Site Request Forgery Vulnerabiltiies (CVE-2011-4403)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.