Database Security Knowledgebase Update 5.03

This month's update for Database Security Knowledgebase is now available.

Knowledgebase version 5.00 includes new checks for Microsoft SQL Server, MySQL, Oracle and Teradata and new CIS policies for MySQL v1.0.2 and Oracle 11gR2 v2.0.0.

New Vulnerability and Configuration Check Highlights

SAP (Sybase) ASE

  • Auditing of authorization checks inside system stored procedures not enabled
    • Ensure that authorization checks inside system stored procedures are being audited.
    • Risk: Medium
    • Relevant CVEs:N/A
  • Residual data removal is not enabled on database level
    • Check if residual data removal is enabled on database level.
    • Risk: Low
    • Relevant CVEs:N/A
  • Threshold Event Monitoring is not enabled
    • Check if Threshold Event Monitoring is enabled.
    • Risk: Low
    • Relevant CVEs:N/A

Updated Checks

SAP (Sybase) ASE

  • Latest patch not applied
    • Check for Sybase ASE 16.0 SP02 PL04 and 15.7 SP137
    • Risk: High
    • Relevant CVEs:N/A
  • Patch not applied on time
    • Check for Sybase ASE 16.0 SP02 PL04 and 15.7 SP137
    • Risk: High
    • Relevant CVEs:N/A

MySQL

  • Latest release not installed
    • Support MySQL 5.5.50 and 5.6.31
    • Risk: High
    • Relevant CVEs:N/A
  • Release update not installed on time
    • Support MySQL 5.5.50 and 5.6.31
    • Risk: High
    • Relevant CVEs:N/A

New Policies

  • DISA-STIG SQL Server 2012 V1R10 -Audit (Built-In)
    • This policy has been created with guidance of the configuration parameters outlined by the DISA-STIG Microsoft SQL Server 2012 Security Technical Implementation Guide Version 1, Release 10
    • Note that AppDetectivePRO users should use the DISA STIG NEW! Policy as the new policies are part of the super set of DISA STIG policies.

Availability

  • Available to allAppDetectivePRO and DbProtect customers with maintenance (subscription or perpetual) in good standing at no additional cost
  • Download SHATTER Knowledgebase from the Trustwave Support Portal (https://www.trustwave.com/Company/Support/ and select AppDetectivePRO or DbProtect)
  • AppDetectivePRO customers can use the Updater within the product as well