TrustKeeper Scan Engine Update for October 07, 2016

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

ISC Bind

  • Bind vulnerable to Denial of Service via a crafted query (improper responses construction in buffer.c) (CVE-2016-2776)

Joomla

  • Cross-site request forgery vulnerability in Joomla! (CVE-2015-8565)
  • Cross-site scripting in Joomla! 1.6.x - 1.6.3 (CVE-2011-4332)
  • Cross-site scripting vulnerabilities in Joomla! 1.5 through 1.5.9 (CVE-2009-1279)
  • Cross-site scripting vulnerabilities in Joomla! 1.5.x - 1.5.7 (CVE-2008-6299)
  • Cross-site scripting vulnerabilities in Joomla! 1.6.x - 1.6.5 (CVE-2011-2710)
  • Cross-site scripting vulnerabilities in the back end in Joomla! 1.5 through 1.5.17 (CVE-2010-1649)
  • Cross-site scripting vulnerabilities in the Back End in Joomla! 1.5.x before 1.5.20 (CVE-2010-2535)
  • Cross-site scripting vulnerability in libraries/idna_convert/example.php in Joomla! 3.1.5 (CVE-2013-5583)
  • Cross-site scripting vulnerability in the JA_Purity template for Joomla! 1.5.x through 1.5.10 (CVE-2009-1939)
  • Directory traversal vulnerability in Joomla! 3.2.0 through 3.3.x and 3.4.x before 3.4.6 (CVE-2015-8565)
  • Faults exist in the administrator application of Joomla! (CVE-2009-1280)
  • Inadequate filtering of request data in Joomla! leads to a SQL Injection vulnerability (CVE-2015-8769)
  • Joomla! 1.6.0 allows remote attackers to obtain sensitive information (CVE-2011-3747)
  • Joomla! before 1.5.12 allows remote attackers to obtain the installation path (CVE-2011-4911)
  • Joomla! before 1.5.15 allows remote authenticated users to gain author privileges (CVE-2009-3945)
  • JRequest in Joomla! 1.5 before 1.5.7 does not sanitize variables (CVE-2008-4105)
  • Multiple open redirect vulnerabilities in Joomla! 1.5 before 1.5.7 (CVE-2008-4104)
  • Multiple SQL injection vulnerabilities in Joomla! 1.5.21 and all previous 1.5 releases (CVE-2010-4166)
  • SQL injection vulnerabilities in Joomla! 1.5.x before 1.5.22 (CVE-2010-4696)
  • The password reset functionality in Joomla! 1.5.x through 1.5.24 uses weak random numbers (CVE-2011-4321)
  • XSS in the login module in Joomla! 3.4.x before 3.4.4 allows remote attackers to inject arbitrary web script (CVE-2015-6939)
  • Cross-site scripting vulnerabilities in 1.5.10 and all previous 1.5 releases (CVE-2009-1938)
  • Cross-site scripting vulnerability in the administrator panel (CVE-2009-1940)
  • SQL injection vulnerability in the getListQuery function 3.2 - 3.4.5 (CVE-2015-7857)
  • Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow PHP object injection (CVE-2015-8562)

OpenSSL

  • OpenSSL 1.1.0 Denial of Service in a call to SSL_peek() function when the peer sends an empty record (CVE-2016-6305)
  • OpenSSL Denial of Service and potential code execution by a peer sending large TLS messages (CVE-2016-6309)
  • OpenSSL Denial of Service via memory exhaust by sending excessively large OCSP Status Request extensions (CVE-2016-6304)
  • OpenSSL Denial of Service via memory exhaustion by a peer sending large DTLS messages (CVE-2016-6308)
  • OpenSSL Denial of Service via memory exhaustion by a peer sending large TLS messages (CVE-2016-6307)
  • OpenSSL Denial of Service via memory exhaustion by a peer sending large TLS messages (CVE-2016-7052)
  • OpenSSL Denial of Service vulnerability in BN_bn2dec function (CVE-2016-2182)
  • OpenSSL Denial of Service vulnerability in DTLS implementation (CVE-2016-2179)
  • OpenSSL Denial of Service vulnerability in DTLS implementation via spoofed DTLS records (CVE-2016-2181)
  • OpenSSL Denial of Service vulnerability in tls_decrypt_ticket function (HMAC size during ticket length validation) (CVE-2016-6302)
  • OpenSSL Denial of Service vulnerability via integer overflow in MDC2_Update function (CVE-2016-6303)
  • OpenSSL potential Denial of Service caused by missing message length check (CVE-2016-6306)

Vulnerabilities for multiple products

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.