ModSecurity 2.5.13 release candidate

Already available a release candidate of 2.5.13 ModSecurity into svn repository (branch 2.5.x).

There are some improvements, new features and bug fixes like :

New features:

* Added new setvar Lua API to be used into Lua scripts

* Added new Base64 transformation function called base64DecodeExt, which
can decode base64 data skipping special characters.

In the past we mentioned this topic here: Impedance mismatch and base64

Improvement

* Added PCRE messages indicates each rule that exceed match limits

* Fixed Geo lookup concurrent connections bug

* Fixed Skip/SkipAfter chain bug

* Cleaned up some mlogc code and debugging output.

* Remove the ability to use a relative path to a piped audit logger
(i.e. mlogc) as Apache does not support it in their piped loggers
and it was breaking Windows and probably other platforms that
use spaces in filesystem paths. Discovered by Tom Donovan.

* Fix memory leak freeing regex. Discovered by Tom Donovan.

* Fix some portability issues on Windows.

If you want to get it and test the new features, just follow the steps:

1 - Create a directory to clone the code:

mkdir /home/brenosilva/svn/modsecurity

cd /home/brenosilva/svn

2 - Clone the source code:

SVN:
svn co https://mo​d-security​.svn.sourc​eforge.net​/svnroot/m​od-securit​y/m2/branc​hes/2.5.x modsecurity

GIT:
git svn clone --prefix=svn/ https://mo​d-security​.svn.sourc​eforge.net​/svnroot/m​od-securit​y/m2/branc​hes/2.5.x modsecurity

3 - Make sure you cloned the last rev:

Checked out HEAD:
https://mo​d-security​.svn.sourc​eforge.net​/svnroot/m​od-securit​y/m2/branc​hes/2.5.x r1544

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.