Privilege Escalation Vulnerability in Cisco ASA's SSL VPN

Trustwave SpiderLabs security researcher Jonathan Claudius has discovered a privilege escalation vulnerability in Cisco ASA's SSL VPN service. Cisco ASA is one of the most popular and widely deployed firewalls in the world. Like most firewalls it provides a variety of features including a client-to-site SSL VPN. This vulnerability allows any user with an established VPN to gain full administrative access to the ASA device.

The vulnerability exists in the SSL VPN web portal. After connecting to the VPN any user can craft a specific URL to execute arbitrary commands on the ASA system. This would initially allow the user to elevate their privilege on the device by creating an administrative account. In turn, the administrative account could be used for full access to the ASA appliance.

Although privilege escalation attacks don't get the same attention as arbitrary code execution, this vulnerability is rather critical. The security of client to site VPNs is often over estimated by many admins because encryption is involved. In truth any VPN is only as secure as the two end points. Many VPN clients are in the hands of "road warriors" that are often targeted with drive-by malware and phishing attacks. VPNs are also often opened up to 3rd party vendors and partners for "secure" access to internal resources.

An attacker exploiting this vulnerability could modify the firewall rule base including dropping all firewall rules. They could turn on packet capturing for all traffic through the appliance and would have administrative access to any additional ASA UTM modules. At the very least the attacker could perform denial of all device services.

Jonathan Claudius will be demonstrating this vulnerability at Chicago' s Thotcon (http://www.thotcon.org/schedule.html) on Friday, April 25th with contributing researcher Laura Guay of Dell SecureWorks. Part of their talk will be demonstrating a metasploit module written to exploit this vulnerability. This PoC will be posted to Trustwave SpiderLabs updated advisory link TWSL2014-005.

Cisco ASA administrators can remediate this vulnerability by applying the latest firmware for your appliance. Depending on the ASA model you will want to upgrade to at least version 8.2(5.48), 8.3(2.40), 8.4(7.15), 8.6(1.13), 8.7(1.11), 9.0(4.1), or 9.1(4.5).

For more information about this vulnerability:

The Trustwave SpiderLabs advisory: https://www3.trustwave.com/spiderlabs/advisories/TWSL2014-005.txt

This vulnerability has been assigned CVE-2014-2127: http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2127

More information can be found on Cisco's website under the heading: http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140409-asa

Registered Cisco customers can find vulnerability details under bug ID CSCul70099: https://tools.cisco.com/bugsearch/bug/CSCul70099

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.