TrustKeeper Scan Engine Update for August 17, 2016

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

PHP

  • PHP before 5.5.37 and 5.6.x before 5.6.23 suffers from an integer overflow (CVE-2016-5770)
  • PHP before 5.5.37 will unserialize during garbage collection (CVE-2016-5771)
  • PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8 has multiple integer overflows in mcrypt.c (CVE-2016-5769)
  • PHP Denial of Service in ext/exif/exif.c (CVE-2016-6291)
  • PHP Denial of Service in ext/intl/collator/collator_sort.c (CVE-2015-8616)
  • PHP Denial of Service in ext/session/session.c (CVE-2016-6290)
  • PHP Denial of Service via bad garbage collection in ext/snmp/snmp.c (CVE-2016-6295)
  • PHP Denial of Service via buffer overflow in the phar_fix_filepath function (CVE-2015-5590)
  • PHP Denial of Service via buffer overflow of smart_str data type in ext/standard/url.c (CVE-2016-6288)
  • PHP Denial of Service via Integer overflow in ext/zip/zip_stream.c (CVE-2016-6297)
  • PHP Denial of Service via Integer overflow in TSRM/tsrm_virtual_cwd.c (CVE-2016-6289)
  • PHP Denial of Service via NULL pointer reference in ext/exif/exif.c (CVE-2016-6292)
  • PHP Denial of Service via restricted calls in ext/intl/locale/locale_methods.c (CVE-2016-6294)
  • PHP Denial of Service via unsigned Integer in simplestring.c (CVE-2016-6296)
  • PHP Directory traversal vulnerability in the PharData class (CVE-2015-6833)
  • PHP HTTPoxy vulnerability (CVE-2016-5385)
  • PHP Remote Code Execution via crafted value in the third argument of the str_ireplace function (CVE-2015-6527)
  • PHP Remote Code Execution via SoapClient __call method in ext/soap/soap.c (CVE-2015-6836)
  • Double free vulnerability in the php_wddx_process_data function allows denial of service attacks (CVE-2016-5772)
  • Double free vulnerability in the _php_mb_regex_ereg_replace_exec function in php_mbregex.c (CVE-2016-5768)

WordPress

  • Cross-site scripting in WordPress before 4.5.3 via the network settings page (CVE-2016-6634)
  • Wordpress before 4.5 allows CSRF via the script compression option (CVE-2016-6635)
  • Wordpress before 4.5 allows for bypass of SSRF protections (CVE-2016-4029)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.