TrustKeeper Scan Engine Update for July 20, 2016

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

MySQL and MariaDB

  • MySQL memcmp Authentication Bypass Vulnerability (CVE-2012-2122)
  • MariaDB memcmp Authentication Bypass Vulnerability (CVE-2012-2122)

phpMyAdmin

  • phpMyAdmin remote PHP code execution via a crafted string (CVE-2016-5734)
  • phpMyAdmin BBCode injection attacks against HTTP sessions via a crafted URI (CVE-2016-5701)
  • phpMyAdmin cookie-attribute injection attacks via a crafted URI (CVE-2016-5702)
  • phpMyAdmin Cross-site Request Forgery attacks related to libraries/Header.php (CVE-2016-5739)
  • phpMyAdmin Cross-site Scripting in examples/openid.php (CVE-2016-5731)
  • phpMyAdmin Cross-site Scripting via comments in the table-structure page (CVE-2016-5704)
  • phpMyAdmin Cross-site scripting via special characters that are mishandled during double URL decoding (CVE-2016-5099)
  • phpMyAdmin Cross-site Scripting vulnerability in display_partitions.phtml (CVE-2016-5732)
  • phpMyAdmin Denial of Service via a large array in get_scripts.js.php (CVE-2016-5706)
  • phpMyAdmin information leakage via tokens in query strings (CVE-2016-5097)
  • phpMyAdmin installation full path disclosure via multiple vectors (CVE-2016-5730)
  • phpMyAdmin Multiple Cross-site Scripting vulnerabilities (CVE-2016-5733)
  • phpMyAdmin Multiple Cross-site Scripting vulnerabilities before 4.4.15.7 and 4.6.3 (CVE-2016-5705)
  • phpMyAdmin SQL injection vulnerability in libraries/central_columns.lib.php (CVE-2016-5703)

Ruby

  • Denial of service vulnerability through the BigDecimal standard library of Ruby (CVE-2009-1904)
  • Invalid X.509 certificates in Ruby (CVE-2009-0642)

Network Time Protocol (ntpd)

  • NTPD Denial of service in 4.2.p8p7 via incorrect patch (CVE-2016-4957)
  • NTPD Denial of Service via a spoofed broadcast packet (CVE-2016-4956)
  • NTPD Denial of service via multiple vectors (CVE-2016-4955)
  • NTPD Denial of Service via sending spoofed packets from many source IP addresses (CVE-2016-4954)
  • NTPD Denial of Service via spoofed crypto-NAK packet (CVE-2016-4953)
  • NTPD Information leakage or Denial of Service via extension field with an invalid value (CVE-2014-9750)
  • NTPD Man-in-the-middle via incorrect MAC field (CVE-2015-1798)
  • NTPD spoofing of restricted packets using the ::1 address (CVE-2014-9751)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.

Trustwave reserves the right to review all comments in the discussion below. Please note that for security and other reasons, we may not approve comments containing links.