Loading...
Security Resources

Software Updates

Database Security Knowledgebase Update 6.07

Trustwave Database Security Knowledgebase (ShatterKB) 6.07 is now available. It introduces new checks for Oracle, MySQL, IBM Db2 LUW, MongoDB, Elasticsearch, updated checks for Teradata, and updates to many of our built-in policies.

New Vulnerability and Configuration Check Highlights

IBM Db2 LUW

  • IBM DB2 db2fm is vulnerable to a buffer overflow (CVE-2020-5025)
  • Check version to determine if the database contains vulnerability described by CVE-2020-5025.
  • Risk: High

 

  • IBM Db2 does not explicitly forbid a weaker than expected 3DES cipher when configured to use SSL (CVE-2019-4102)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4102.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to a buffer overflow (CVE-2019-4014)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4014.
  • Risk: High

 

  • IBM DB2 is vulnerable to a buffer overflow (CVE-2020-4701)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4701.
  • Risk: High

 

  • IBM Db2 is vulnerable to a denial of service (CVE-2020-5024)
  • Check version to determine if the database contains vulnerability described by CVE-2020-5024.
  • Risk: High

 

  • IBM Db2 is vulnerable to a denial of service attack (CVE-2020-4420)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4420.
  • Risk: High

 

  • IBM Db2 is vulnerable to a Denial of Service on Windows (CVE-2020-4642)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4642.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to an information disclosure (CVE-2020-4386)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4386.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to an information disclosure (CVE-2020-4387)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4387.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to an information disclosure and denial of service (CVE-2020-4414)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4414.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to buffer overflow (CVE-2019-4154)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4154.
  • Risk: High

 

  • IBM Db2 is vulnerable to buffer overflow leading to a privileged escalation (CVE-2020-4363)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4363.
  • Risk: High

 

  • IBM Db2 is vulnerable to denial of service (CVE-2019-4101)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4101.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to denial of service (CVE-2019-4386)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4386.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to denial of service (CVE-2020-4135)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4135.
  • Risk: High

 

  • IBM Db2 is vulnerable to denial of service (CVE-2020-4161)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4161.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to denial of service (CVE-2020-4200)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4200.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to information disclosure (CVE-2019-4438)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4438.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to information disclosure (CVE-2019-4524)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4524.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to privilege escalation (CVE-2019-4587)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4587.
  • Risk: High

 

  • IBM Db2 is vulnerable to privilege escalation (CVE-2020-4230)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4230.
  • Risk: Medium

 

  • IBM Db2 is vulnerable to privilege escalation to root via malicious use of fenced user (CVE-2019-4057)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4057.
  • Risk: High

 

  • IBM Db2 is vulnerable to privilege escalation via loading libraries from an untrusted path (CVE-2019-4094)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4094.
  • Risk: High

 

  • IBM Db2 is vulnerable to weak file permissions allowing access to specific files (CVE-2020-4976)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4976.
  • Risk: Medium

 

  • IBM Db2 may be vulnerable to a denial of service attack (CVE-2020-4355)
  • Check version to determine if the database contains vulnerability described by CVE-2020-4355.
  • Risk: Medium

 

  • Multiple buffer overflow vulnerabilities exist in IBM Db2 leading to privilege escalation (CVE-2019-4015)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4015.
  • Risk: High

 

  • Multiple buffer overflow vulnerabilities exist in IBM Db2 leading to privilege escalation (CVE-2019-4016)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4016.
  • Risk: High

 

  • Multiple buffer overflow vulnerabilities exist in IBM Db2 leading to privilege escalation (CVE-2019-4322)
  • Check version to determine if the database contains vulnerability described by CVE-2019-4322.
  • Risk: High

 

Elasticsearch

  • Enable operator privileges
  • Verify that operator privileges are enabled.
  • Risk: Medium

 

  • IP filtering
  • Reports list of all configured IP filtering rules.
  • Risk: Informational

 

MongoDB

  • Vulnerability in MongoDB Server - CVE-2018-25004
  • Check version to determine if the database contains vulnerability described by CVE-2018-25004.
  • Risk: Medium

 

  • Vulnerability in MongoDB Server - CVE-2020-7929
  • Check version to determine if the database contains vulnerability described by CVE-2020-7929.
  • Risk: Medium

 

MySQL

  • Critical Patch Update - April 2021
  • Check version to determine if the database contains vulnerabilities described by Critical Patch Update - April 2021.
  • Risk: High

 

Oracle

  • Critical Patch Update/Patch Set Update - April 2021
  • Check version to determine if the database contains vulnerabilities described by Critical Patch Update/Patch Set Update - April 2021.
  • Risk: High

Updated Checks

Teradata

  • Latest patch not applied
  • Risk: High

Updated Policies

  • Full list of policy updates is available in the readme file located in the support portal

Availability

  • Available to all AppDetectivePRO and DbProtect customers with maintenance (subscription or perpetual) in good standing at no additional cost. 
  • Download SHATTER Knowledgebase from the Trustwave Support Portal. (https: //www.trustwave.com/Company/Support/ and select AppDetectivePRO or DbProtect)
  • AppDetectivePRO customers can use the Updater within the product as well