Loading...
Security Resources

Software Updates

TrustKeeper Scan Engine Update for February 21, 2020

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!


New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

ClamAV

  • ClamAV Data-Loss-Prevention Feature Denial of Service Vulnerability (CVE-2020-3123)

FreeBSD

  • FreeBSD IPsec Package Reply Vulnerability (FreeBSD-SA-20:02.ipsec) (CVE-2019-5613)
  • FreeBSD Kernel Stack Data Disclosure Vulnerability (FreeBSD-SA-20:03.thrmisc) (CVE-2019-15875)
  • FreeBSD libfetch Buffer Overflow Vulnerability (FreeBSD-SA-20:01.libfetch) (CVE-2020-7450)

Joomla

  • Joomla Core Account Creation Privilege Escalation Vulnerability (20120303) (CVE-2012-1563)
  • Joomla Core batch actions Cross-Site Request Forgery Vulnerability (20200101) (CVE-2020-8419)
  • Joomla Core com_actionlogs Cross-Site Scripting Vulnerability (20200103) (CVE-2020-8421)
  • Joomla Core com_mailto Timeout Bypass Vulnerability (20090723) (CVE-2011-4912)
  • Joomla Core com_templates Cross-Site Request Forgery Vulnerability (20200102) (CVE-2020-8420)
  • Joomla Core filter_order SQL Injection Vulnerability (20110201) (CVE-2011-1151)
  • Joomla Core index.php Cross-Site Scripting Vulnerabilities (20110902) (CVE-2011-3595)
  • Joomla Core Information Exposure Vulnerability (20111002) (CVE-2011-4937)
  • Joomla Core JEXEC Path Disclosure Vulnerability (20090722) (CVE-2011-4907)
  • Joomla Core Password Reset Vulnerability (20120304) (CVE-2012-1562)

Microsoft

PHP

  • PHP fsockopen Improper Input Validation Vulnerability (CVE-2017-7189)

Splunk

Squid

  • Squid Proxy Cache ext_lm_group_acl Denial of Service Vulnerability (SQUID-2020:3) (CVE-2020-8517)
  • Squid Proxy Cache FTP Gateway Information Disclosure Vulnerability (SQUID-2020:2) (CVE-2019-12528)
  • Squid Proxy Cache HTTP Request Input Validation Vulnerability (SQUID-2020:1) (CVE-2020-8450, CVE-2020-8449)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.