Security Resources

Software Updates

TrustKeeper Scan Engine Update for September 05, 2018

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!

 


 

New Vulnerability Test Highlights

  • Coverage for 23 new vulnerabilities
  • Added version-based test coverage for Cisco ASA, FreeBSD, ISC BIND, Joomla!, Microsoft Exchange, Microsoft SQL Server and VMWare ESXi.
  • Added active test coverage for Ruby, Spring Data REST and SuperMicro IPMI.
  • Added informational test coverage for Apache HTTP Server and Splunk.

Some of the more interesting vulnerability tests we added recently are as follows:

Apache

  • Apache HTTP Server Default Files

Cisco

  • Cisco ASA Flow Creation Denial of Service Vulnerability (cisco-sa-20180418-asa2, CSCvf63718) ( CVE-2018-0228)
  • Cisco ASA VPN SSL Client Certificate Bypass Vulnerability (cisco-sa-20180418-asa1, CSCvg40155) ( CVE-2018-0227)

FreeBSD

  • FreeBSD L1 Terminal Fault (L1TF) Kernel Information Disclosure Vulnerability (FreeBSD-SA-18:09.l1tf) ( CVE-2018-3646, CVE-2018-3620)

ISC

  • ISC BIND deny-answer-aliases Assertion Failure Denial of Service (AA-01639) ( CVE-2018-5740)

Joomla

  • Joomla! Core com_fields Filter Field Remote Code Execution ( CVE-2018-11321)
  • Joomla! Core Installer Password Leak Vulnerability ( CVE-2018-11325)
  • Joomla! Core Media Manager Multiple Cross Site Scripting Vulnerabilities ( CVE-2018-6378)
  • Joomla! Core Multiple Cross Site Scripting Vulnerabilities ( CVE-2018-11326)
  • Joomla! Core Redirect Cross Site Scripting Vulnerability ( CVE-2018-11328)
  • Joomla! Core Restriction Bypass for Privileged Tags ( CVE-2018-11327)
  • Joomla! Core Restriction Bypass for User Groups ( CVE-2018-11323)
  • Joomla! Core Updater Race Condition Vulnerability ( CVE-2018-11324)

Microsoft

  • Microsoft Exchange Server Memory Corruption Vulnerability (2018-Aug) ( CVE-2018-8302)
  • Microsoft Exchange Server Tampering Vulnerability (2018-Aug) ( CVE-2018-8374)
  • Microsoft SQL Server Remote Code Execution Vulnerability (2018-Aug) ( CVE-2018-8273)

PHP

  • Joomla! Core Potential PHP Archive files Execution Vulnerability ( CVE-2018-11322)

Ruby

Splunk

  • Splunk Informational Check

Spring DATA REST

  • Spring Data REST PATCH requests Remote Code Execution ( CVE-2017-8046)

SuperMicro IPMI

  • SuperMicro IPMI Web Interface Port 49152 Sensitive File Exposure Vulnerability

VMware ESXi

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.