Security Resources

Software Updates

TrustKeeper Scan Engine Update for September 19, 2018

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!

 


 

New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Apache

  • Apache Struts Remote Code Execution Vulnerability (S2-057) ( CVE-2018-11776)
  • Apache Tomcat Async Race Condition Information Information Leak ( CVE-2018-8037)
  • Apache Tomcat CORS Filter Insecure Default Settings ( CVE-2018-8014)
  • Apache Tomcat Security Constraint Bypass Vulnerability ( CVE-2018-8034)
  • Apache Tomcat UTF-8 Decoder Overflow Vulnerability ( CVE-2018-1336)

Cisco

  • Cisco ASA Bleichenbacher (ROBOT) Attack on TLS Vulnerability (cisco-sa-20171212-bleichenbacher, CSCvg97652) ( CVE-2017-12373)
  • Cisco ASA HREF Cross-Site Scripting Vulnerability (cisco-sa-20171004-asa1, CSCve91068) ( CVE-2017-12265)
  • Cisco ASA Remote Code Execution and Denial of Service Vulnerability (cisco-sa-20180129-asa1) ( CVE-2018-0101)
  • Cisco ASA Software Direct Authentication Denial of Service Vulnerability (cisco-sa-20171004-asa, CSCvd59063) ( CVE-2017-12246)
  • Cisco ASA WebVPN Cross-Site Scripting Vulnerability (CSCsy82093) ( CVE-2009-1220)

VMWare ESXi

phpMyAdmin

  • PhpMyAdmin Designer feature Cross-site Scripting Vulnerability (PMASA-2018-3) ( CVE-2018-12581)
  • PhpMyAdmin index.php Remote Code Execution Vulnerability (PMASA-2018-4) ( CVE-2018-12613)

Ruby

  • Ruby Fiddle::Function class Heap Overflow Vulnerability ( CVE-2016-2339)
  • Ruby Regular Expression Library Denial Of Service Vulnerability ( CVE-2017-6181)
  • Ruby Resolv::Hosts#lazy_initialize Command Injection Vulnerability ( CVE-2017-17790)
  • Ruby REXML Entity expansion denial of service vulnerability ( CVE-2014-8090)
  • Ruby URI.decode_www_form_component method denial of service vulnerability ( CVE-2014-6438)
  • Ruby WIN32OLE#ole_invoke and WIN32OLE#ole_query_interface methods type confusion vulnerabilities ( CVE-2016-2336)

SSL

  • SSL Certificate Chain Not Trusted (Internal Scan)
  • SSL Certificate Common Name Does Not Validate (Internal Scan)

FreeBSD

  • FreeBSD Kernel ELF Header Parsing Kernel Memory Disclosure Vulnerability (FreeBSD-SA-18:12.elf) ( CVE-2018-6924)
  • FreeBSD Kernel IP Reassembly Denial of Service Vulnerability (FreeBSD-SA-18:10.ip) ( CVE-2018-6923)
  • FreeBSD Kernel TCP Reassembly Denial of Service Vulnerability (FreeBSD-SA-18:08.tcp) ( CVE-2018-6922)
  • FreeBSD WPA Unauthenticated EAPOL-Key Decryption (FreeBSD-SA-18:11.hostapd) ( CVE-2018-14526)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.