Loading...
Security Resources

Software Updates

Trustwave Web Application Firewall 4.56

Trustwave SpiderLabs is pleased to announce the release of CorSigs version 4.56 for Trustwave Web Application Firewall (WAF) versions 8.5 and 9.0. These rules are written to detect attacks or classes of attacks on web applications and their components.

Release Summary

This release includes the following new signatures inclusion:

  • Microsoft Exchange Server Crafted Request Empty Host Header Handling Internal IP Address Disclosure
    Microsoft Exchange Server allows a remote user to enumerate Exchange user and environment information which could lead to gather information about the internal network.

 

  • Microsoft IIS 6.0 - ScStoragePathFromUrl WebDAV Buffer Overflow
    Buffer overflow in the ScStoragePathFromUrl function in the WebDAV service (IIS 6.0) allows remote attackers to execute arbitrary code via a long string in the vulnerable parameter.

 

  • CVE-2015-8562: Joomla! PHP unseralization RCE
    Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via the HTTP User-Agent header

 

  • Magento /index.php/admin/Cms/Wysiwyg/ Code Injection
    Magento eCommerce platform allows an unauthenticated attacker to execute PHP code on the web server via the vulnerable parameter

 

  • CVE-2018-5989: Joomla! Component ccNewsletter 2.x.x SQLi
    The ccNewsletter 2.x.x component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • Joomla! Component EkRishta 2.10 SQLi
    The EkRishta 2.10 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • Joomla! Component EkRishta 2.10 SQLi
    The EkRishta 2.10 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6394: Joomla! Component InviteX 3.0.5 SQLi
    The InviteX 3.0.5 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.
  • CVE-2018-6372: Joomla! Component JB Bus 2.3 SQLi
    The JB Bus 2.3 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5970: Joomla! Component jGive 2.0.9 SQLi
    The jGive 2.0.9 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6368: Joomla! Component JomEstate PRO 3.7 SQLi
    The JomEstate PRO 3.7 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5983: Joomla! Component JquickContact 1.3.2.2.1 SQLi
    The JB Bus 2.3 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6006: Joomla! Component JS Autoz 1.0.9 SQLi
    The JB Bus 2.3 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5994: Joomla! Component JS Jobs 1.1.9 SQLi
    The JB Bus 2.3 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-10188: phpMyAdmin 4.8.0-1 SQLi
    phpMyAdmin 4.8.0-1 has CSRF, allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6609: Joomla! Component JSP Tickets 1.1 SQLi
    The JSP Tickets 1.1 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6585: Joomla! Component JTicketing 2.0.16 SQLi
    The JTicketing 2.0.16 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5971: Joomla! Component MediaLibrary Free 4.0.12 SQLi
    The MediaLibrary Free 4.0.12 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6024: Joomla! Component Project Log 1.5.3 SQLi
    The Project Log 1.5.3 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

   

  • CVE-2018-5974: Joomla! Component SimpleCalendar 3.1.9 SQLi
    The SimpleCalendar 3.1.9 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5975: Joomla! Component Smart Shoutbox 3.0.0 SQLi
    The Shoutbox 3.0.0 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5992: Joomla! Component Staff Master 1.0 RC 1 SQLi
    The Staff Master 1.0 RC 1 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-6583: Joomla! Component Timetable Responsive Schedule 1.5 SQLi
    The Timetable Responsive Schedule 1.5 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • CVE-2018-5987: Joomla! Component Pinterest Clone Social Pinboard 2.0 SQLi

The Pinterest Clone Social Pinboard 2.0 component for Joomla! allows a remote user to execute arbitrary SQL commands via the vulnerable parameter.

 

  • WordPress Plugin Metronet Tag Manager 1.2.7 CSRF
    The Metronet Tag Manager 1.2.7 plugin for WordPress allows an unauthenticated attacker with network access via HTTP to compromise vulnerable component, resulting with server data corruption or leakage.

 

How to Update

No action is required by customers running versions 8.5 or 9.0 of Trustwave Web Application Firewall and whom subscribe to the online update feature. Their deployments will update automatically.

Please note that even if blocking actions are defined for a protected site, Simulation Mode for these rules is ON by default in order to allow site managers to inspect the impact of new rules before blocking relevant traffic. If you want to activate blocking actions for this rule, you must update the Actions for this signature in the Policy Manager.