Loading...
Security Resources

Software Updates

Web Application Security ModSecurity Commercial Rules Update for July 2021

Overview for rules released by Trustwave SpiderLabs in July for ModSecurity Commercial Rules package. The rules are available for versions 2.9.x and 3.x of ModSecurity.


ModSecurity Commercial Rules detect attacks or classes of attacks on web applications and their components as well as provide virtual patches for public vulnerabilities.

 

Release Summary

Pandora FMS <= 7.54 XSS CVE-2021-35501

WordPress Theme Newsmag < 5.0 -Unauthenticated Reflected XSS CVE-2021-24304

WordPress Plugin W3 Total Cache < 2.1.4 - Reflected XSS in Extensions Page CVE-2021-24436

WordPress Plugin Awesome Weather Widget <= 3.0.2 - Reflected XSS CVE-2021-24474

WordPress Plugin ProfilePress < 3.1.11 - Unauthenticated XSS in tabbed login/register widget CVE-2021-24522

WordPress Plugin AceIDE <= 2.6.2 Authenticated Arbitrary File Access CVE-2020-24549

Ampache 4.4.2 XSS

osCommerce <= 2.3.4.1 Unauthenticated RCE

SolarWinds Serv-U FTP Server 15.2.3 Share URL XSS CVE-2021-32604

WordPress Plugin Super Progressive Web Apps < 2.1.12 - Authenticated (Low Privileged) Arbitrary File Upload to RCE

Microsoft SharePoint Server - RCE CVE-2021-34467

WordPress Plugin Activity Log < 2.7.0 - Authenticated SQLi

WordPress Plugin WooCommerce Blocks 2.5-5.5 - Unauthenticated SQLi CVE-2021-32789

WordPress Plugin WooCommerce 3.3-5.5 - Authenticated SQLi CVE-2021-32790

WordPress Plugin WPFront Notification Bar <= 1.9.1.04012 - Stored XSS

WordPress Plugin Filebird 4.7.3 - Unauthenticated SQLi CVE-2021-24385

WordPress Plugin ProfilePress 3.0 -  3.1.3 - Arbitrary File Upload in Image Uploader Component CVE-2021-34623

WordPress Plugin ProfilePress 3.0 -  3.1.3 - Arbitrary File Upload in File Uploader Component CVE-2021-34624

WordPress Plugin ProfilePress 3.0 -  3.1.3 - Authenticated Privilege Escalation CVE-2021-34622

WordPress Plugin ProfilePress 3.0 -  3.1.3 - Unauthenticated Privilege Escalation CVE-2021-34621

ModSecurity 3.0.0-3.0.4 - Incorrect handling of URI fragments in request line

 

How to Update

All the rules released this month are available for download and can be configured using the ModSecurity Dashboard. The rules are associated with the default profile and enabled for all licensed servers. To verify the rules were successfully downloaded by ModSecurity, log in to the ModSecurity Dashboard and verify the server "Last seen" date, which indicates the last successful download for the specified server.